(SOLVED) Can not SSH/SFTP to iPhone

Mobile Support
Post Reply
User avatar
ADF-Sniper
Admin - Founder
Admin - Founder
Posts: 2914
Joined: Sat Jul 19, 2003 12:00 am
Location: Wangaratta, Australia
Contact:

(SOLVED) Can not SSH/SFTP to iPhone

Post by ADF-Sniper »

The problem I was faced was that after SSH to my device I did not exit cleanly by typing "exit" in shell. After a number of connections I was then locked out. What made it worse is that Filezilla would not drop the connections after multiple transfers, which resulted in me being locked out.

Anyway it's a very simple fix.
First what we want to do is create a timeout and then set a maximum amount of ssh connections rather then its default.

Navigate to /ect/ssh and edit the file "sshd_config"
There will be two lines that are commented out.

Default
#ClientAliveInterval 0
#ClientAliveCountMax 3

Change to what you require for me it would be.
ClientAliveInterval 5
ClientAliveCountMax 10

Ok first 5 is the amount of seconds of disconnected inactivity
and 10 is the amount of max SSH connections.


Next....
Navigate to /ect/ssh and edit the file "ssh_config" and add these lines
ConnectTimeout 10
TCPKeepAlive yes

Details on ssh_config file Here
http://linux.die.net/man/5/ssh_config


Now Reboot.

SOLVED!
As always please reply and say thanks :)


Enjoy
Evolution is just so unlikely to produce complex life forms.
Image

Post Reply